Issues with the release

Incident Report for CELUS Design Platform

Resolved

After a post-release QA run, we can confidently say that everything seems stable and resolved.
Posted Jul 02, 2025 - 12:58 CEST

Monitoring

We traced the disruption to transient instability at our ingress layer. A proxy restart seems to have restored normal performance, and Design Studio is operating normally again. We’ll keep an eye on things to ensure everything stays stable.
Posted Jul 02, 2025 - 11:24 CEST

Investigating

We’re investigating an issue that’s causing elevated latency and intermittent outages in Design Studio. Our engineers are working to restore normal performance as quickly as possible. Further updates will be posted here.
Posted Jul 02, 2025 - 10:20 CEST
This incident affected: app.celus.io (Web Application).